Results 1 to 4 of 4

Thread: Cannot launch Windows 8 Store (DCOM error 2)

  1. #1
    Bryn is offline Junior Member
    Join Date
    Mar 2012
    Posts
    1
    Downloads
    0
    Uploads
    0

    Cannot launch Windows 8 Store (DCOM error 2)

    I have recently installed the Windows 8 consumer preview and not able to start Windows Store with one of my domain accounts. Whenever I try to do that then I get the error saying that it cannot start DCOM Server: Windows.Store because this is unavailable. This error comes with the title DCOM error 2. It shows me:

    This happened while starting this command:

    "C:\Windows\System32\WWAHost.exe" -ServerName:Windows.Store

    Windows 8 that I am using on my computer is a fresh install of Windows 8. I am using the Samsung Series 7 Slate. There is no problem when I try to launch the same with the local account. Both the accounts that I am using is the Administrator account. I am not able tp understand that what is the problem with that and how that can be resolved. So I am posting this over here so that I gcan get some suggestion for this from the people over here. Thank you so much in advance for replies.


  2. #2
    OObuntu is offline Member
    Join Date
    Jan 2012
    Posts
    37
    Downloads
    0
    Uploads
    0
    Make sure that you have set the local launch and local activation for "everyone" along with the administrators. You can do this from the DCOM settings (component services). If you have not done this then you will surely face problem with that. So do this and see if it helps you to get the problem resolved or not. If this also failed to work for you then there is just one option for you and that is to delete the profile from which you are having problem and then create a new profile again with the same rights. See if that can solve the problem for you. Many people do not prefer this method because they have to setup all the things again which is irritating. But if no other option is working for you then you are just left with this option only. Good Luck!!!

  3. #3
    James is offline Member
    Join Date
    Jan 2012
    Posts
    51
    Downloads
    0
    Uploads
    0
    There are some of the users who have posted that they have resolved this problem when they ran Win8 Refresh and so this is really worth to try it once. For this, you can go to search > Settings > Refresh. There are very less chances for this but some of the times change in the resolution can also be the reason for this problem. So, just try by changing the resolution and see if changing the resolution works for you. I am running mine with resolution of 1920x1200. There is no problem with the resolution. These are the only two things that I can suggest you. Anyways, this is not the final version of the Windows 8 and so this is obvious that you will get problems like this. I am quite sure that the final version of this will be free of such bugs and we will not have issues like this.

  4. #4
    Mr.Cupid is offline Member
    Join Date
    Jan 2012
    Posts
    33
    Downloads
    0
    Uploads
    0
    As you have mentioned that the problem is just happening with the Domain accounts and if this is the case then there are more chances that you are having group policy which is pushing the custom security template otherwise some additional security setting which is removing "All Application Packages" group from the registry file or COM ACL. There is one simple test that you can do with this. All you have to do is, just connect a broken machine in a workgroup and after that refresh your computer so that it can restore default security. If that resolves the problem and re-joining the domain again shows you the same problem then this is domain admin will have to examine that what is the security setting that leads to removing "All Application Packages". I hope that this will be helpful to you.

Similar Threads

  1. Unable to launch The Sims 3 Town Life Stuff
    By $Blair$ in forum PC Gaming
    Replies: 7
    Last Post: 03-28-2012, 11:09 PM
  2. Unable to launch Team Fortress 2
    By Clouds in forum PC Gaming
    Replies: 7
    Last Post: 03-22-2012, 03:33 AM
  3. Replies: 6
    Last Post: 03-10-2012, 12:13 AM
  4. 0x800704ec error while trying to start Windows defender
    By The$Hope in forum PC Softwares and Applications
    Replies: 8
    Last Post: 03-07-2012, 02:45 AM
  5. Replies: 7
    Last Post: 02-23-2012, 04:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •